Le logiciel de mesure et réception DVB-S / DVB-S2 pour votre MiniTiouner ou MiniTiounerPro

Minitioune v.7 est verrouillé (LEDs vertes)mais pas de vidéo

Messagede F6DZP » Jeu 29 Mar 2018 05:05

Bonjour,

Je viens de recevoir ce message:
Bonsoir Jean Pierre , ce message pour avoir votre avis sur un petit problème rencontré plusieurs fois :
Je fais de l’émission/réception DATV S avec en réception le MiniTioune v0.7b et le module acheté au REF , de temps en temps l’image n’apparait pas à l’écran de mes correspondants alors que tout est au vert, le MER à plus de 20 dB, etc .... . Ce matin lors d’un essai nous avons eu ce problème , à l’émission j’ai une carte DATV express et le soft v 1.26 d’Evariste . Ce matin j’émettais avec un SR de 1MHz en DVB S en H264 . A moment donné je suis passé en émission en DVB-S2 et la miraculeusement après avoir relancé MiniTioune l’image est apparue . Ensuite nous sommes repassé en DVB-S et l’image est apparue immédiatement !!!

Merci d’avance

73
Jacques F6BKI


Comme cela peut arriver à d'autres je mets ici ma réponse:

Bonjour Jacques,

Je ne peux pas te donner de réponse exacte, il me faudrait plus d'info, le mieux : une capture écran. de Minitioune +une capture écran de datv express transmit

En gros, Il y a plusieurs possibilités quand on bien est verrouillé (=toutes les Leds vertes) et que on ne voit pas la vidéo:

1) le flux TS émis par la DATVexpress ne contient pas de vidéo,
ça m'arrive régulièrement avec ma DATVexpress, suivant le réglage de capture webcam, le SR et les fameux réglages de l'encodage. Le TS est bon mais pas les flux élémentaires, eux mal encodés. parfois ça démarre bien parfois non et on ne sait pas toujours pourquoi. Un moyen de tester est d’enclencher le bouton UDP de Minitioune et de lancer VLC en UDP pour voir si VLC aussi ne décode rien. la partie capture et encodage Mpeg2 ou H264 du soft DATVexpress n'est vraiment pas fiable/facile à gérer.

- Le fux TS émis par la DATVexpress est OK mais

2) Minitioune est verrouillé le flux TS présent (LEDTS verte) mais Minitioune ne le reçoit pas à cause d'un problème de récupération USB , cela se détecte en regardant le nb de "bytes received" / octets reçus. Si le nombre ne bouge pas, on est dans ce cas.
ça peut arriver de temps en temps avec la version 0.7, cela se corrige immédiatement en changeant de fréquence et revenant sur la fréquence. c'est un cas assez rare, mais ça peut arriver.

3) Minitioune est verrouillé le flux TS présent (LED TS verte) et Minitioune le reçoit bien via USB, il est envoyé alors au système de décodage de windows qui choisit le codec Mpeg2/H264 et décode. Parfois on ne voit pas la vidéo car le système de décodage s'est mal initialisé car démarré au milieu d'un paquet TS. on va donc relancer le codec: si on est en H264, on clique sur Mpeg2 puis revient sur H264 et on voit alors la vidéo.
c'est un cas qui peut arriver de temps en temps avec la version 0.7 et les grands utilisateurs ont le réflexe du clic Mpeg2/H264.
La version 0.8 bientôt disponible semble bien supprimer ces problèmes en faisant bien attention à l'alignement des paquets TS pour que le décodeur reçoive à coup sûr le flux à partir d'un début de paquet

4)) Minitioune est verrouillé le flux TS présent (LED TS verte) et Minitioune le reçoit bien via USB et est prêt à décoder mais n'a pas trouvé les tables DVB qui donnent les PIDs et le codec , pour différentes raisons: elles ne sont pas incluses dans le TS (par ex = bug du Minimod de l'ISS) ou elles sont envoyées trop lentement et Minitioune n'a pas attendu assez longtemps pour les trouver ... Il suffit de mettre les PIDs et codec à la main pour corriger ce problème.
La version 0.8 est complètement revue pour renforcer le décodage des tables DVB en AutoPID et fait un travail quasi parfait sur ce sujet même avec les très grand SR des satellites Broadcast (c'est surtout ce cas là qui posait des problèmes avec la version 0.7).
Mais si les tables ne sont pas envoyées, autoPID ne pourra quand même pas les trouver, là c'est coté émission qu'il faut corriger

Voilà en gros les principales raisons possibles.
Il faudrait en savoir plus sur ce qui s'est passé pour savoir dans quel cas on est.
comme tu as changé les paramètres de la DATV express et est revenu au mode précédent ça peut être un problème de son coté, mais ça peut aussi être le cas 2 ou 3.

73
Jean-Pierre F6DZP
F6DZP
 
Messages: 696
Inscription: 24 Déc 2010

Forums Statistiques

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

Options

Retourner vers MiniTioune