Build your own USB tuner

Help analyze error

Messagede lhucin » Ven 11 Nov 2016 23:20

Hi all.
I have MiniTiouner (FT2232 + NIM) but with Minitioune v04c do not decode Mpeg2 DVBS signal. I checked install drivers and SW on three different PCs with the same result.
On one of pc is instaled TechnoTrend S2-3200 card and Tutioune 3200 v0.2b and decoding is OK. I presume that there is installed correct video filters and codecs. But Minitiouner do not decode video.
For testing I use Raspberry Pi with RpiDatv SW and IQmodulator from PA0RJV.

Tuti_3200.JPG
Tuti_3200.JPG (298.16 Kio) Vu 3313 fois

Correctly decoded signal on TTS2-3200

NIM+FTD.JPG
NIM+FTD.JPG (211.95 Kio) Vu 3313 fois

The same test signal and the same PC, but different SW and Minitiouner.

TestMyMiniTiouner_v1_3a says the following:

DLL version: 3.2.7
we have found 2 device(s)
............................................
device 0:
device named: USB <-> NIM tuner A
For I2C, we will use this device
FT2232H I2C is open
Handle: 11025936
............................................
device 1:
device named: USB <-> NIM tuner B
For TS, we will use this device
FT2232H FIFO open for TS
Handle: 11018416
FT2232H FIFO closed for TS
............................................
USB driver version: 2.8.24
==========================================================================
------ IP and UDP detection ------
IP n° 1 = 10.57.66.52
UDP address : 127.0.0.1 port : 1234 using IP interface : 127.0.0.1
==========================================================================
****************** I2C controler INIT *******************
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
***********************************************************
Trying to get the Demodulator serial number
we get the value = 32
Demodulator is a STV0903
NIM is a Samsung/Sharp or LG
-------------------------------------------------------------------------
trying to write $5A=90 in register X
writing $5A at address X seems OK
trying to read 1000 times register X
time to do it : 1328msec
we have : 0 reading errors from 1000
test: 512 writing/reading the Demodulator
we have : 0 writing errors and 0 reading errors from 512
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
STV0903 Demodulator setup for DVBS
----------------------------------------------------------------------
Writing demodulator default values ==> OK
time to do it: 860msec
STV0903 Init OK
writing $5A at address X seems OK
we try to do 1000 readings of register X after demodulator init
time to do it : 1812msec
we have : 0 reading errors from 1000
test: 512 writing/reading the Demodulator after initialization
we have : 0 writing errors and 0 reading errors from 512
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Init ZeroTuner Sharp/Samsung
----------------------------------------------------------------------
ZeroTuner initialization ==> OK
Reading values in STV6110 registers
Reading STV6110 is OK
FT2232H FIFO open for TS
Done ...I=0 FT_Q_Bytes= 0
Done ...I=0 FT_Q_Bytes= 0
FT2232H FIFO closed for TS
FT2232H I2C is closed


Anyone have any idea what is wrong??
How can I verify that the data from NIM pass through the FIFO to USB port and to SW decoder??

Many thanks for your cooperation.

Vy 73!
OK2UUJ Leo
lhucin
 
Messages: 2
Inscription: 21 Aoû 2016

Re: Help analyze error

Messagede F6DZP » Sam 3 Déc 2016 08:13

Hello,

Sure Your NIM is receiving the TS ( we can see the number of byte received) and you have it on the pin out of the NIM, but your PC doesn't seem to receive it.
So I suppose that there is a hardware problem between the NIM and the FT2232H
Using an oscilloscope, check if you have the signal that says that data are available at the output of the 74HC10.

You can also try to change the use of the TS error bit in Minitioune software ( CTRL + A to get the extra panel and change the TS error bit from ON to OFF)

Jean-Pierre F6DZP
F6DZP
 
Messages: 668
Inscription: 24 Déc 2010

Re: Help analyze error

Messagede lhucin » Sam 3 Déc 2016 22:46

Hello Jean-Pierre

I tested the strobe signal for FIFO (output the 74HC10) and it is OK. Burst of many 1us impulses are repeated every 1ms.
I checked the PCB and finded the microscopic short circuit between two data pin on NIM conector. After resoldering and cleaning PCB the Minitiouner working OK .
Bingo!!!
Many thanks for your cooperation.

Now are necessary precisely adjusted rotator with antene and waiting for Proxima ATV transmision :-) :-)

Many greetings from Czech republic.

Vy 73!
Leo OK2UUJ
lhucin
 
Messages: 2
Inscription: 21 Aoû 2016

Forums Statistiques

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

Options

Retourner vers MiniTiouner