Fabriquez vous-même votre boitier Tuner USB pour le DVB-S/S2 performant en très bas débit

Pb détection du NIM

Messagede f6big » Mar 14 Mar 2017 16:50

Minitioune rapide ...
Windows 10
USB driver 2.12.24
DLL version 3.2.12
Tout ok sauf NIM and Demodulateur detection :
Write_register function failure
Une piste ?
73 de Jean-Pierre F6BIG
f6big
 
Messages: 8
Inscription: 18 Sep 2016

Re: Pb détection du NIM

Messagede F6DZP » Mar 14 Mar 2017 19:14

Bonjour,
Minitioune rapide ...

je ne comprends pas ce que ça veut dire;

description trop vague.
avec quel logiciel?

Que donne
1) TestMyMini Tiouner_v1_3b. Y at-il bien 0 erreurs?
si la réponse est non pas la peine de tester le reste mais faire une capture de la zone texte et la mettre ici pour que l'on comprenne ce qui se passe et quand.

2) "CheckMiniTiouneDriverAndFilters V0_3a" toutes leds sont-elles vertes?
si la réponse est non pas la peine de tester le reste mais faire une capture de la zone texte et la mettre ici pour que l'on comprenne ce qui se passe et quand.

3) Minitioune V0.5a ou 06.e ne doit être lancé que si les étapes 1 et 2 ont été OK.


Tout ok sauf NIM and Demodulateur detection :
Write_register function failure

tout OK? non pas grand chose, juste l'install du driver FT2232H est OK mais pas la suite du montage.
Ici je pense qu'il y aura sûrement erreur dès le test 1), on ne peut rien (lire??) écrire car "Write_register function failure" via I2C, donc impossible de savoir si il y a un NIM ou un demod au bout de la ligne I2C

je mets "on ne peut rien (lire??) écrire " car trop peu d'info sont données, faire plutôt une capture de la liste des messages

de toute façon il y a un problème du à un mauvais montage, vérifier
- les valeurs des alim
- les soudures,
mais ce serait surtout l'I2C qui fonctionne mal, mais ça le test 1) doit le montrer

si c'est le circuit du BATC il ne faut surtout pas souder les capa C11 et C13, ça bousille les signaux I2C.

Jean-Pierre F6DZP
F6DZP
 
Messages: 665
Inscription: 24 Déc 2010

Re: Pb détection du NIM

Messagede f6big » Mar 14 Mar 2017 21:50

Que donne
1) TestMyMini Tiouner_v1_3b. Y at-il bien 0 erreurs?
si la réponse est non pas la peine de tester le reste mais faire une capture de la zone texte et la mettre ici pour que l'on comprenne ce qui se passe et quand.

==========================================
Résultats de ces tests :
DLL version: 3.2.12
we have found 2 device(s)
............................................
device 0:
device named: USB <-> NIM tuner A
For I2C, we will use this device
FT2232H I2C is open
Handle: 7441520
............................................
device 1:
device named: USB <-> NIM tuner B
For TS, we will use this device
FT2232H FIFO open for TS
Handle: 7605728
FT2232H FIFO closed for TS
............................................
USB driver version: 2.12.24
==========================================================================
------ IP and UDP detection ------
IP n° 1 = 192.168.0.9
UDP address : 127.0.0.1 port : 1234 using IP interface : 127.0.0.1
==========================================================================
****************** I2C controler INIT *******************
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
***********************************************************
Trying to get the Demodulator serial number
ERREUR: impossible to read the value
============================================================


2) "CheckMiniTiouneDriverAndFilters V0_3a" toutes leds sont-elles vertes?
si la réponse est non pas la peine de tester le reste mais faire une capture de la zone texte et la mettre ici pour que l'on comprenne ce qui se passe et quand.

Résultats de ces tests :
========================================xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
DLL detection
----------------------------------------------------------------------
DLL version: 3.2.12
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
USB channels detection
----------------------------------------------------------------------
we have found 2 device(s)
............................................
device 0:
device named: USB <-> NIM tuner A
For I2C, we will use this device
Handle: 149115688
............................................
device 1:
device named: USB <-> NIM tuner B
For TS, we will use this device
Handle: 149114528
............................................
USB driver version: 2.12.24
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
I2C initialisation
----------------------------------------------------------------------
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
***********************************************************
------ NIM and Demodulator detection ------
Write_register function failure

===================================================================================

je mets "on ne peut rien (lire??) écrire " car trop peu d'info sont données, faire plutôt une capture de la liste des messages

de toute façon il y a un problème du à un mauvais montage, vérifier
- les valeurs des alim
- les soudures,
mais ce serait surtout l'I2C qui fonctionne mal, mais ça le test 1) doit le montrer

si c'est le circuit du BATC il ne faut surtout pas souder les capa C11 et C13, ça bousille les signaux I2C.

C'est un CI CHF/2015 Batch F5XG 2016

73 de Jean-Pierre F6BIG
f6big
 
Messages: 8
Inscription: 18 Sep 2016

Re: Pb détection du NIM

Messagede F6DZP » Mer 15 Mar 2017 17:16

Donc dès le premier test on voit que le MiniTiouner ne fonctione pas.

Le FT2232H lui est bien alimenté et bien programmé.

dès qu'on veut détecter le NIM on ne trouve rien, parce que:
>>> le NIm n'est pas bien alimenté ' vérifier le 3.3v et 1V sur les mins du NIM
>>> les pistes du dialogue I2C sont inutilisables : vérifier les pistes SDA et/ou SCL , y a t-il bien continuité jusqu'au NIM? Y at-il bien les résistances de tirage avec la bonne valeur ( 4,7k vers le +3.3V)?
il ne doit pas y avoir de capa sur ces lignes et je trouve bizarre ces résistances en série qu'il y a sur le schéma de f1CHF

Bref pour moi, si toutes les soudures sont bonnes, les alim bonnes et le NIM pas QRT, c'est bien les lignes LDA et SCL qui sont à vérifier, les signaux 12C ne passent pas.

Jean-Pierre f6DZP
F6DZP
 
Messages: 665
Inscription: 24 Déc 2010

Re: Pb détection du NIM

Messagede F1CHF » Mer 15 Mar 2017 18:15

le DZP a dit
"il ne doit pas y avoir de capa sur ces lignes et je trouve bizarre ces résistances en série qu'il y a sur le schéma de f1CHF" oh lui .... des kits Minitiounes y'en a eu 100 dans la nature, mais je sais pas combien furent cablés !
coté I2C y'a bien deux resistances 4.7K de tirage au +3,3 volts (R1 et R2)
ensuite on a R5 et R6 en série (c'est "con" mais c'etait pour faciliter le passage des pistes !) 22 Ohms ou autre !
et de l'autre coté on a R4 a 47 Ohms (ou autre) en série, ces résistances ne sont pas du tout obligatoires !
faut bien faire attention au positionnement ... pas de court jus avec les pistes.
et surtout pas de capas .. d'abord y'a pas de capas !
voila voila
le CHF
F1CHF
 
Messages: 49
Inscription: 29 Déc 2010

Re: Pb détection du NIM

Messagede F6DZP » Mer 15 Mar 2017 22:05

woui woui je sais que ces résistances en série n'ont pas empêché des tas de kits de fonctionner.
Mais si une 47 ohm est par mégarde remplacée par une plus grande valeur ça peut commencer à disturber le signal.
et comme elles ne sont pas obligatoires...
bref on cherche à faire marcher l'I2C du copain, donc faut bien ressouder ou dessouder qque chose...

coté I2C y'a bien deux resistances 4.7K de tirage au +3,3 volts (R1 et R2

woui zossi, je sais qu' elles sont sur le schéma mais sont-elles soudées sur le CI ?
bref, on cherche des pistes

les capas c'est sur le kit du BATC qu'on peut en mettre par mégarde, j'ai des OMs récemment qui ont séché sur le problème pendant plusieurs jours...

Jean-Pierre
F6DZP
 
Messages: 665
Inscription: 24 Déc 2010

Re: Pb détection du NIM

Messagede f6big » Jeu 16 Mar 2017 16:57

F6DZP a écrit:Donc dès le premier test on voit que le MiniTiouner ne fonctione pas.

Le FT2232H lui est bien alimenté et bien programmé.

dès qu'on veut détecter le NIM on ne trouve rien, parce que:
>>> le NIm n'est pas bien alimenté ' vérifier le 3.3v et 1V sur les mins du NIM
>>> les pistes du dialogue I2C sont inutilisables : vérifier les pistes SDA et/ou SCL , y a t-il bien continuité jusqu'au NIM? Y at-il bien les résistances de tirage avec la bonne valeur ( 4,7k vers le +3.3V)?
il ne doit pas y avoir de capa sur ces lignes et je trouve bizarre ces résistances en série qu'il y a sur le schéma de f1CHF

Bref pour moi, si toutes les soudures sont bonnes, les alim bonnes et le NIM pas QRT, c'est bien les lignes LDA et SCL qui sont à vérifier, les signaux 12C ne passent pas.

=========================
Les broches 2-1, 2-3 et 2-5 du 2232 réunies entres elles sur le CI ne sont pas réunies directement au 3,3v ...
Les 2 résistances de 4,7 k sont aussi câblées sur ce point commun.
Sur le CI aucune connexion de ce point commun vers le 3,3 .... ???.
Faut-il donc mettre un strap (inexistant sur le CI) entre ce point et le 3,3 ?
Ce serait logique si ce point doit être alimenté en 3,3 !
Sure le schéma du CHF aucun renvoi de cette équipotentielle vers le point d'alim 3,3 ... d'où peut-être un oubli sur le CI, mais si c'est le cas cela devrait déjà être connu.
73 de Jean-Pierre F6BIG
=============================

Jean-Pierre f6DZP
f6big
 
Messages: 8
Inscription: 18 Sep 2016

Re: Pb détection du NIM

Messagede f6big » Ven 17 Mar 2017 22:12

Du nouveau !
J'ai eu un doute sur le modèle de NIM reçu ...
Une datasheet parlait de VDD à 1.25 ...
J'ai donc mis une alim 1.25 à la place de la 1.000 ...
Il semble bien se confirmer que ce n'est pas le bon modèle de NIM malgré la bonne référence portée sur la facture et la commande.
Sur le NIM lui-même c'est presque effacé .... ce qui m'as mis la puce à l'oreille !

Et voilà ce que je retrouve maintenant dans les tests concernants le NIM :
=================
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
I2C initialisation
----------------------------------------------------------------------
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
***********************************************************
------ NIM and Demodulator detection ------
STV0903 Identification correct : chip_ident($F), release($8).
writing test failed: 0
======================================
et
====================================
==========================================================================
****************** I2C controler INIT *******************
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
***********************************************************
Trying to get the Demodulator serial number
we get the value = 248
ERROR : Unknown Demodulator
=========================================================

Donc je vais rechercher le bon modèle !

73 de Jean-Pierre F6BIG
f6big
 
Messages: 8
Inscription: 18 Sep 2016

Re: Pb détection du NIM

Messagede F6DZP » Dim 19 Mar 2017 12:34

qu'est ce que c'est comme NIM?
quelle référence ou début de référence si c'est effacé? une photo?
le mieux est d'ouvrir le boitier métal et regarder le nom du chip zero tuner et le nom du chip demodulateur. Avec ça on sait tout de suite l'alim qu'il faut et si c'est compatible avec Minitioune

Si il y a un STV0903 dedans il doit être alimenté en 1V
Si il y a un STV0913 ou STV0910 il doit être alimenté en 1.1v

pour l'instant je n'ai jamais utilisé de NIM alimenté en 1.25v, même le "vieux" STB0899 était alimenté en 1V

Jean-Pierre F6DZP
F6DZP
 
Messages: 665
Inscription: 24 Déc 2010

Re: Pb détection du NIM

Messagede f6big » Dim 19 Mar 2017 15:04

F6DZP a écrit:qu'est ce que c'est comme NIM?
quelle référence ou début de référence si c'est effacé? une photo?
le mieux est d'ouvrir le boitier métal et regarder le nom du chip zero tuner et le nom du chip demodulateur. Avec ça on sait tout de suite l'alim qu'il faut et si c'est compatible avec Minitioune

Si il y a un STV0903 dedans il doit être alimenté en 1V
Si il y a un STV0913 ou STV0910 il doit être alimenté en 1.1v

pour l'instant je n'ai jamais utilisé de NIM alimenté en 1.25v, même le "vieux" STB0899 était alimenté en 1V


Merci pour ta réponse.
Comme tu as pu lire avec 1.25 il y avait bien un dialogue puisque par exemple la référence du ship était bien récupérée.
Je te passe joint 3 photos via email de la bête.
Le début de la référence semble F7VZ1
73 de Jean-Pierre F6BIG


Jean-Pierre F6DZP
f6big
 
Messages: 8
Inscription: 18 Sep 2016

Suivante
Forums Statistiques

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

Options

Retourner vers MiniTiouner