Fabriquez vous-même votre boitier Tuner USB pour le DVB-S/S2 performant en très bas débit

miniTioune V2 stopped working

Postby flyham » Sun 26 Jan 2020 15:35

Built up the miniTiouner recently for QO-100 and its been working fine for a few weeks, but now its stopped working.

I've tried many things, some obvious, some less so, like new USB lead, reloading v0.09 software on to my Win 7 , reload filters, using v0.08 etc etc but it show no signs of going.

It shows all the signs of not receiving any signal as carrier lock is 0 as is SR lock and the LNB gain figure is fluctuating wildly. Sometimes if you cycle the wide lock or change from LNB A to B and back it will lock, but quitting the s/ware and rebooting it fails to lock again.

I've gone over all the solder joints on the pcb and checked the 12V out to the LNB is there and it is.

The test routines all seem to run okay although it doesn't recognise the SERIT module automatically but has to be prompted. I have also reprogrammed the FT2232 module to no avail.

Currently I have it sitting on a known good signal source i.e a Freesat channel on my own 60cms Freesat system using its own dedicated LNB, and coax cable. I get the occasional very good lock but most times it doesn't. So looks like it absolves my QO-100 LNB?

I have been inside the tuner with a magnifier and nothing in the way of solder splashes in there.

Any ideas??

73 de G8BKE
flyham
 
Posts: 4
Joined: 31 Dec 2019

Re: miniTioune V2 stopped working

Postby F6DZP » Mon 27 Jan 2020 06:02

Hello,

I need more information to answer ( PC processor, %CPU used, other USB peripheral used at same time ...?, LNB used ? do have you measure the PPM correction, do you know the LNB offset, how many kHz does it slip evry mn after sending the 13v or 18v ...).

it doesn't recognise the SERIT module automatically

My first Idea is that the 5v power supply given by your PC to the FT2232h minimodule is not good , not enought mA. this is the only design I don't like on the MiniTiouner V2. ( MiniTiouner V1 was powering itself the FT2232H) . several people have made the modification on their MiniTiounerV2 to give 3.3v needed by the FT2232H chip from the 3.3v MiniTiounerV2 board itself, not from the 5V given by the PC via USB plug and regulated by a 3.3V regulator chip on the Minimodule.
check if you have good 3.3v on the FT2232H

Other investigation need more information


Jean-Pierre
F6DZP
 
Posts: 1034
Joined: 24 Dec 2010

Re: miniTioune V2 stopped working

Postby flyham » Mon 27 Jan 2020 12:22

The PC is a Dell laptop 6520 running 64 bit Win 7. Intel core i52420 2.5Ghz processor, 4Gb memory. CPU usage with mini running is ~25%

No other USB peripherals on the USB bus.

"USB 5volts" measures 4.99V from PC with mini plugged in

LNB in use is the GM201. LNB seems to work best with LO set as 9750110

I checked the FT module. Vc input is 4.99V. Regulated voltage for the chip from 4.99V is 2.22V. I think this is incorrect! ?

Something has failed as mini used to be okay?

73 de Chris



Hi again,

Since writing the above .... I have lifted the output lead of the 5V> 3.3V regulator on the FT module and fed in a 3.3V from the main Mini PCB.

This has cured the lock problem. It seems that the regulator may be faulty?

The only drawback now is that the I2C performance seems to have been compromised. It shows "0 %" in the bar on the I2C performance test. Before
it was ~75% on the same USB lead?

The boot up time of the overall s/ware is now about 15 secs. and not 5 as it was before!

Any further thoughts?
flyham
 
Posts: 4
Joined: 31 Dec 2019

Re: miniTioune V2 stopped working

Postby F6DZP » Mon 27 Jan 2020 17:56

Regulated voltage for the chip from 4.99V is 2.22V. I think this is incorrect! ?


yes.
but
I2C performance seems to have been compromised. It shows "0 %" in the bar on the I2C performance test


I think the best could be to change your MiniModule FT2232H that seems to be bad on different way.

Jean-Pierre F6DZP
F6DZP
 
Posts: 1034
Joined: 24 Dec 2010

Re: miniTioune V2 stopped working

Postby flyham » Mon 27 Jan 2020 19:53

Maybe change yes. I wonder why its failed?

Not cheap either!

Thanks for your help.

73 Chris
flyham
 
Posts: 4
Joined: 31 Dec 2019

Re: miniTioune V2 stopped working

Postby flyham » Thu 30 Jan 2020 12:36

Replaced the USB module with a new one. All voltages seem correct now. But tests show the I2C performance is only about 14% whereas it was 78% before on the same USB lead.

Also boot up time into MINITIOUNE v0.09 still ~30 seconds and screen response to cursor button inputs is very slow.

Your thoughts?

73 de Chris
flyham
 
Posts: 4
Joined: 31 Dec 2019

Forum Statistics

Who is online

Users browsing this forum: No registered users and 1 guest

Options

Return to MiniTiouner

cron